Uppgradera PHP hos Loopia

För att uppgradera din hemsida hos Loopia till en senare PHP-version gör du enligt följande:

1. Se över din hemsidas programkod

Vi rekommenderar att du ser över din hemsidas programkod innan uppgraderingen för att försäkra dig om att den är kompatibel med den senare PHP-versionen. Då kommer din hemsida att fortsätta fungera som tidigare efter uppgraderingen. Gör så här:

WordPress

  • Uppgradera WordPress samt alla installerade tillägg/teman. Läs här för information om hur du gör detta.
  • Uppgradera alla premiumtillägg/-teman samt specialgjorda tillägg/teman på det sätt som tillverkaren rekommenderar.
  • Avinstallera eller ersätt alla tillägg/teman som inte stödjer den PHP version du avser uppgradera till.
  • Se vår guide om hur du felsöker WordPress om det ej fungerar efter flytt.

Joomla

  • Se denna guide om hur du aktiverar felmeddelanden på din sida
  • Uppgradera Joomla samt alla installerade tillägg/mallar. Läs här för information om hur du uppgraderar Joomla.
  • Uppgradera alla premiumtillägg/-mallar samt specialgjorda tillägg/mallar på det sätt som tillverkaren rekommenderar.
  • Avinstallera eller ersätt alla tillägg/mallar som inte stödjer den PHP version du avser uppgradera till.

OpenCart

  • Se denna guide om hur du aktiverar felmeddelanden på din sida
  • Uppgradera OpenCart samt alla installerade tillägg/mallar. Läs här och här för information om hur du uppgraderar OpenCart.
  • Uppgradera alla premiumtillägg/-mallar samt specialgjorda tillägg/mallar på det sätt som tillverkaren rekommenderar.
  • Avinstallera eller ersätt alla tillägg/mallar som inte stödjer den PHP version du avser uppgradera till.

Övriga

Notera att om du programmerat din sida själv med mysql_*-funktioner behöver du byta dem till mysqli eller PDO. Har du en senare version av WordPress/Joomla/OpenCart använder du redan korrekta databasanslutningar.

2. Uppgradera PHP-version i Loopia Kundzon

    1. Logga in i Loopia Kundzon.
    2. Klicka på domännamnet för den hemsida du vill uppgradera PHP för och välj “Hemsida hos Loopia” > “Unix”.
    3. Välj önskad PHP-version och klicka på “Spara”.

Samtliga PHP-versioner körs på servrar med Apache 2.4.

Internal Server Error

Från PHP version 7.1 har vi ingen bakåtkompabilitet med utdaterad kod i htaccess-filer. Det betyder att allow/deny-kommandon och även AddOutputFilterByType kan generera Internal Server Error på sidan. Se denna guide om hur du åtgärdar detta för att kunna köra den senaste PHP-versionen på din hemsida.

Hjälpte denna artikel dig?

Relaterade artiklar